Skip to content

Lightrun Python agent system requirements

The following page describes the IDE and operating system requirements for running the Lightrun Python agent.

Supported operating systems

OS Requirements
Linux - Python versions 3.8 to 3.11
- Alpine Linux versions 3.16, 3.17, 3.18 and 3.19 (libstdc++ is required to use Lightrun in Alpine Linux)
- Ubuntu LTS versions 20.04, and 22.04. (Linux with GLIBCXX_3.4.19 and later)
- CentOS versions 7, 8, and 9 versions (Linux with GLIBCXX_3.4.19 and later)
Windows OS - Python versions 3.8 to 3.11
- Windows Server versions 2016 (limited), 2019, and 2022
macOS - Python versions 3.8 to 3.11
- macOS versions 12.O and higher for Apple Chipset based Macs
AWS Lambda Python versions 3.8 to 3.11

Lightrun IDE Plugins


Last update: April 17, 2024