Skip to content

Lightrun for Python - System Requirements

Lightrun has two main parts - the Lightrun Agent and the Lightrun Plugin. Please see the requirements below for each:

Installation Component Requirements
Production Machines (Python Agent) - Python v2.7 or Python v3.6-v3.9
- Linux with GLIBCXX_3.4.19 or newer (Ubuntu 14+, Centos 7+ or equivalent)
Developer Machines (IDE Plugin) - JDK/OpenJDK 1.8 or newer
- PyCharm 2018.3 / 2019.3 / 2020.1

Last update: September 27, 2021