Skip to content

On-premises deployment system requirements

Lightrun requires the following system components:

Installation Component Requirements
Agent • JDK/OpenJDK 1.7 or newer
• Linux with GLIBCXX_3.4.19 or newer (Ubuntu 14+, Centos 7+ or equivalent)
IntelliJ plugin • JDK/OpenJDK 1.8 or newer
• IntelliJ Idea 2018.3 / 2019.3 / 2020.1
Management server • 4 GB of RAM
• 4 CPU cores
• 16 GB of storage
• Linux with GLIBCXX_3.4.19 or newer (Ubuntu 14+, Centos 7+ or equivalent)
• Docker 1.10.0+. Kernel version >= 4.4

Last update: May 5, 2021