Skip to content

Lightrun Node.js agent system requirements

The following page describes the IDE and operating system requirements for running the Lightrun Node agent.

Supported operating systems

OS Requirements
Linux - Node versions 12.0.0 and later
- Alpine Linux versions 3.16, 3.17, 3.18, and 3.19
- Ubuntu LTS releases versions 20.04, and 22.04. (Linux with GLIBCXX_3.4.19 and later)
- CentOS versions 7, 8, and 9 (Linux with GLIBCXX_3.4.19 and later)
Windows OS - Node versions 12.0.0 and later
- Windows Server versions 2016 (limited), 2019, and 2022
macOS - Node versions 12.0.0 and later
- macOS versions 12.O and higher for Apple Chipset based Macs
AWS Lambda - Node versions 12.0.0 and later

Lightrun IDE Plugins


Last update: March 3, 2024