Skip to content

Lightrun for Node.js

Version Support

The instructions below apply to Node.js Version V10+. If you're interested in support for earlier versions, please reach out and let us know!

TypeScript Support

Lightrun does not yet support TypeScript, but we are hard at work building it. Sign up for our beta program to be the first to know when it is released!

In order to start working with Lightrun for Node.js please follow the steps below:

  1. Create a Lightrun account.
  2. Install the Lightrun Plugin for your IDE.
  3. Install the Lightrun Agent and run it with your application. If you're looking to get started with Lightrun with a specific Node.js framework, choose the relevant one from the sidebar menu.

Last update: September 27, 2021