Skip to content

Lightrun Java agent system requirements

The following page describes the IDE and operating system requirements for running the Lightrun JVM agent.

Supported operating systems

OS Requirements
Linux - Java versions 8, 11, 17, 21, and 22
- Alpine Linux versions 3.16, 3.17, 3.18, and 3.19 (libstdc++ is required to use Lightrun in Alpine Linux)
- Ubuntu LTS versions 20.04, and 22.04. (Linux with GLIBCXX_3.4.19 or later)
- CentOS versions 7, 8, and 9 (Linux with GLIBCXX_3.4.19 or later)
Windows OS - Java versions 8, 11, 17, 21, and 22
- Windows Server versions 2016 (limited), 2019, and 2022
macOS - Java versions 8, 11, 17, 21, and 22
- macOS versions 12.O and higher for Apple Chipset based Macs

Lightrun IDE Plugins


Last update: July 21, 2024