Skip to content

Lightrun .NET agent system requirements

This page describes the IDE, operating system, and port requirements for running the Lightrun .NET agent.

Supported Operating Systems

OS Requirements
Linux - Ubuntu : .NET and .NET Core versions (5.0, 6.0, 7.0, 8.0)
- Alpine Linux : Versions 3.16, 3.17, 3.18, and 3.19
Windows OS - .NET and .NET Core versions (5.0, 6.0, 7.0, 8.0)
- .NET Framework v4.6.2 or later.
- Windows Server 2016 (limited), 2019, and 2022
macOS - .NET and .NET Core versions (5.0, 6.0, 7.0, 8.0)
- macOS versions 12.0 and higher for Apple Chipset based Macs.

Lightrun IDE Plugins


Last update: July 21, 2024